Model Unit not Arriving at Destination

  • November 12, 2016 at 03:50 #16371
    Jin
    Participant

    I tested this using all the default values and model from the examples provided. The ground is a flat plain, so the destination is not set in the air.

    Occasionally, the model unit will not reach its destination and will start turning left and right non stop. This usually happens when the unit is about to reach the last cell destination but does not enter it.

    It will occur more often if the cell size is large (e.g. 5-10). Are the any plans to fix this? If not, how would you suggest I solve this?

    November 14, 2016 at 11:39 #16387
    Geminior
    Keymaster

    Issues with jittering model units are usually caused by the destination being somewhere in the air so the unit is unable to reach it. Could that be the case here?

    November 14, 2016 at 12:50 #16395
    Jin
    Participant

    Nope, the ground is totally flat and there are no obstacles or height varying platforms. This happens pretty often actually if you click long enough using the default settings.

    Its quite easy to reproduce this issue:

    1. Create a plane and use it as the ground.
    2. Add 2 or more cubes and add the vector field and other required components to it.
    3. Set the grid cell size to 5.
    4. Click anywhere and the issue will occur easily :(

    November 14, 2016 at 15:45 #16401
    Geminior
    Keymaster

    I see, we will have to investigate that.
    I am unable to give you a time on when we will be able to do so however.

You must be logged in to reply to this topic.