Heightmap issues; AI floats up on start

  • September 4, 2018 at 23:28 #23706
    chaosriftgames
    Participant

    I’ve had a plethora of frustrating issues since purchasing. The AI used to just drop through the ground. Once it would drop waist deep then pathfind…

    My latest issues is with heightmaps. When they are turned off, no issues, Agent runs to the 4 waypoints.

    however when “Generate Heigh Map” is clicked on, as soon as the scene starts it floats up a few units.

    The scene is extremely basic. A ground plane on the “Terrain” layer and 3 cubes set to “Static Obstacle”. I haven’t even gotten to the dynamic obstacles tutorial yet because of this issue.

    September 5, 2018 at 10:41 #23709
    Geminior
    Keymaster

    In what layer did you put the moving unit?
    Clearly something in your setup is off, but what exactly is hard to say from the data available.

    If it makes sense, I would recommend that you remove all Apex Components and add them all again using the quick starts.
    Otherwise have a look at the examples in the examples project, and compare to your own example.

    If all else fails, you can send the project to support(at)apexgametools.com and we will have a look when able.

    September 5, 2018 at 13:00 #23711
    chaosriftgames
    Participant

    I got it working later.

    What happened is I set up all my layers then imported the examples which had a project settings. This wiped out my layers and added in just Apex’s. My unit ended up on the terrain layer, so it’d show on the grid as “unwalkable”. I’d hit play and he’d have nowhere to run so would just float straight up.

    I now have the very basics working with Behavior Designer and Ootii’s Motion controller. Dynamic obstacle avoidance is fantastic.

    September 5, 2018 at 16:49 #23713
    Geminior
    Keymaster

    Glad to hear you got it sorted :)

You must be logged in to reply to this topic.