Height mapping is not doing quite what I would like

  • June 10, 2018 at 15:29 #23342
    Nathan1_
    Participant

    Hello thank you for building this tool it seems really useful and well made. I’ve got a level I’m working on, it’s an island made of simple geometry. The pathing should not be able to climb these slopes but when I switch to Accessability mode it looks like it is at least drawing lines where there shouldn’t be any.

    The slopes are 45 degrees at least everything is 1x1x1 meter in size.

    https://imgur.com/a/Lp6iosx

    June 10, 2018 at 15:35 #23344
    Nathan1_
    Participant

    I have tried setting max slope angle to 0 with the same result. Which other setting am I missing? I feel like I might have more questions sometime later after this one.

    June 10, 2018 at 15:38 #23346
    Nathan1_
    Participant

    Ohhhh, those green lines are descent only.

    I have reduced the max drop height to 0.4 and now there are no green lines. Sorry, I was scratching my head longer than I should have.

    June 10, 2018 at 16:07 #23348
    Nathan1_
    Participant

    Since I’ve already made this thread I’ll ask.

    In order for Apex Path to initialise, I need to have a few layers set. One for terrain and so on. This is all ok. My game requires the player to be able to navigate up and down between ‘floors’ in the mountain. I had it set up so that each floor was on a different layer and then used layer culling on the camera to make the things that were on each floor visible or invisible.

    It seems Apex Path needs to use layers – I can only assign one layer to each object in my scene.

    What would be the easier route?

    1. I can fuss with Apex Path to make it use Tags, or
    2.I can try and use Tags in a custom layer culling type of implementation.

    June 11, 2018 at 10:31 #23351
    Rami
    Keymaster

    Hey Nathan1,

    Glad to hear you worked out your slope problems.

    In regards to the layers, is there anything preventing you from assigning all the floor layers to the “Terrain Layer” setting on the Apex Game World?

    June 11, 2018 at 16:26 #23357
    Nathan1_
    Participant

    Imagine from the screenshot earlier. There is a ground plane that is sand and a mountain side that is rock. That rock mountain side is part of a different layer than the sand. I need both to register as terrain for the Game World so that units cannot walk through the side of the mountain. However both need to be on different layers, so that I can hide the rock layer, for example.

    June 11, 2018 at 16:46 #23359
    Nathan1_
    Participant

    Come to think of it.

    I’m going to have a similar issue with units and everything else, my solution using layers for what I am doing (hiding and showing floors of the island) is wrong. I cannot assign all units and everything on every floor to a certain layer just to be able to hide them.

    The way Apex Path does it is probably correct. I’ll have to find a different way to hide and show elements to the camera.

    Any hints? haha

    June 11, 2018 at 17:05 #23361
    Rami
    Keymaster

    Well Tags, as you mentioned, is one option – if you do go with that, I recommend Constants so you help yourself avoid typos in your code.

    Alternatively, you probably already have a component on most of your stuff – just make an enum or integer value that you assign on the component and test against that, would be my suggestion.

    June 11, 2018 at 17:21 #23366
    Nathan1_
    Participant

    Rami thanks for your help. Renderer instance .enabled is what I am looking for, it seems. I’ll take this problem from here. Really appreciate the support because I’ll likely have more questions in the future about Apex Path and hopefully they are really difficult.

    https://docs.unity3d.com/ScriptReference/Renderer-enabled.html

    :)

You must be logged in to reply to this topic.