DefaultSteeringTransientUnitGroup.MoveTo is not working

  • August 8, 2016 at 17:13 #13459
    Bert
    Participant

    Hi,

    I am trying to get Apex Steer to work, but I am missing something.

    This is the code I am using, when issuing group.MoveTo, the units don’t move…

    Now, if instead, I replace the last line with th following, the units find a path, and move to the target position:

    Questions:
    1) What am I missing to make group.MoveTo work?

    2) I compared our project to one of the examples.. and the only difference is that the example is using Steer For Point Component, and the Quick Start > Navigation Unit created:
    Steer For Path, and Steer For Separation. However, I don’t see Steer For Point in the available components.

    Thanks,
    Bert.

    August 8, 2016 at 18:11 #13463
    Geminior
    Keymaster

    You need to add vector field steering to the units. So instead of the Navigating Unit quick start, apply the Vector Field Navigation quick start.

    You can apply that to unit even though you have already applied another quick start, it will simply add what is missing.

    August 9, 2016 at 03:54 #13476
    Bert
    Participant

    After doing this, now at runtime, I am getting hundreds of this error:

    So… I removed all Apex Path/Steer components from the scene, prefabs, etc. And used the ‘Vector Field Navigation’ quick start again. But the error still remains.

    I checked and the ‘Game World’ has all the components (Load Balancer Component, etc).

    Next.. I removed everything.. and removed Apex Path/Steer from the project/disk, and restarted Unity. Reimported both Apex Path/Steer. Repeated the same steps, and still get the same error.

    • This reply was modified 1 year, 4 months ago by Bert.
    August 9, 2016 at 11:30 #13517
    Geminior
    Keymaster

    You are using the full source distribution I can see.
    Do you still have an Apex Binaries folder?
    If so that is the problem, its either or. You can install using the full source distribution or using the default one.

    The error you are getting makes little sense, are you sure you are not getting other errors as well?

    If none of the above are the cause, then we will need some more information to spot what has gone wrong in your installation/configuration.
    The easiest is to send us the/a project at support(at)apexgametools.com to show the issue.

    December 29, 2016 at 22:02 #17390
    kyle
    Participant

    I was running into the exact same problem this week and it was from starting my scene with the wrong quick start. It might be useful to know how to switch to using Vector Field Navigation without creating an entirely new scene.

You must be logged in to reply to this topic.