AI Repair Error (AI file cannot be opened)

  • July 19, 2017 at 22:00 #21451
    CrytivoGames
    Participant

    Hello.

    We have a strange situation with one of our AI files. On all computers we’ve tried it opens just fine, on windows and on mac os. But, on 1 pc with windows 10 it gives and error and start ai repair tool.

    Here is the error.

    The problem is that selecting ai in repair list and pressing proceed we result with following image:
    result
    Pressing complete and loading repaired ai loads an empty editor. If we try to open that ai again, repair tool is started one more time, with same results.

    Could you please advise what can be done, what should we check/update etc.

    Thank you.

    August 1, 2017 at 11:23 #21582
    Rami
    Keymaster

    Hi Crytivo,

    Make sure that you update Apex Utility AI and Unity on the given computer, to match the other computers. Also make sure that the assembly/code state is exactly the same. The important point is that any files/classes that the AI depends on for loading (Actions, scorers, qualifiers, selectors, custom data types, utility classes, etc.) must be present for the AI to be loadable.

    Apart from that, I’m not sure what else to say. If you are using version control, perhaps try recloning on the machine in question?

    August 5, 2017 at 14:58 #21642
    CrytivoGames
    Participant

    The problem was that one of our scorers had a defined constructor. When we removed it everything worked as expected.

You must be logged in to reply to this topic.